Ejecutar Javascript en una versión de Safari

1 minuto

HTML5 y CSS3

No encontrado nada parecido en foros, por lo que comparto mi solución. Es un pequeño script en Javascript para ejecutar alguna acción si estamos en un Safari de una versión concreta o inferior.

// Comprobar si es Safari 10 o inferior
var userAgent = navigator.userAgent;
var versionSafari = 10;
if ((
    userAgent.indexOf('Safari') !== -1
    && userAgent.indexOf('Chrome') === -1
    && parseInt(userAgent.split('Version/')[1].split('.')[0]) <= versionSafari
) {
    alert('Soy Safari 10 o inferior!');
}

Si queréis cambiar la versión de Safari para comprobar, solo hay que cambiar la variable versionSafari.

Esta obra está bajo una Licencia Creative Commons Atribución-NoComercial-SinDerivadas 4.0 Internacional.

Atribución/Reconocimiento-NoComercial-SinDerivados 4.0 Internacional

¿Me ayudas?

No te sientas obligado a realizarme una donación, pero cada aportación me ayuda a mantener el sitio en activo para que continúe existiendo y me motiva a continuar creando nuevo contenido.

Comprame un café
Pulsa sobre la imagen
  • 1 café: Se mantiene el dominio durante 4 meses.
  • 2 cafés: Se liquida 1 mes del Servidor Web.
  • 3 cafés: Se paga 1 mes de Newsletter.

Comentarios

{{ comments.length }} comentarios

Nuevo comentario

Nueva replica  {{ formatEllipsisAuthor(replyComment.author) }}

Acepto la política de Protección de Datos.

Escribe el primer comentario

Tal vez también te interese...