Instalar Ruby

A la hora de gestionar Ruby suele ser problemático instalar librerías (gemas) cuando estamos trabajando con permisos de usuario. Por mucho que nos seduzca usar sudo ni mucho menos es lo más correcto. ¿Qué hacemos? Crear un entorno virtual, especificando la versión que necesitamos y aislando las versiones de las gemas para evitar conflictos con otros software que se estén ejecutando en la máquina. Así evitaremos el descorazonador mensaje:

$gem install bundler
ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /var/lib/gems/2.3.0 directory.

Vamos a ello.

1. Instalar rbenv.

En Ubuntu/Debian.

sudo apt install rbenv

En MacOS.

brew install rbenv

2. Concretar versión.

He decidido para el ejemplo usar la versión 2.7.1. Ejecuto el siguiente comando.

rbenv install 2.7.1

Cuando termine de descargar las dependencias lo marco como global para mi usuario.

rbenv global 2.7.1

En mi archivo de configuración .bashrc indico las rutas de los nuevos binarios.

echo 'export PATH="$HOME/.rbenv/versions/2.7.1/bin:$PATH"' >> ~/.bashrc

3. Compruebo la instalación.

ruby -v

Si te devuelve 2.7.1 todo ha ido bien.

Ya puedo tranquilamente instalar cualquier gema sin problemas.

Versión escritorio